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Software AG Designer 10.7 Readme 

October 2020 

This file contains important information you must read before using Software AG Designer 10.7. You 
can find system requirements, user documentation, and installation and upgrade instructions on the 
Documentation website or the TECHcommunity website. At those locations, you can also find suite-
related security and globalization information. 

Included in this file is information about functionality that has been added, removed, deprecated, or 
changed for this product. Deprecated functionality continues to work and is supported by Software 
AG, but may be removed in a future release. Software AG recommends against using deprecated 
functionality in new projects. 

 

1.0 Critical Information .................................................................................................................................2 

2.0 Known Issues ............................................................................................................................................2 

3.0 Usage Notes ...............................................................................................................................................3 

4.0 Fixes Included in Each Release .............................................................................................................4 

5.0 Other Resolved Issues .............................................................................................................................5 

6.0 Documentation Changes ........................................................................................................................9 

7.0 Added, Removed, Deprecated, or Changed Items ........................................................................... 11 

8.0 Copyright Information .......................................................................................................................... 13 

9.0 Support ..................................................................................................................................................... 14 

 

http://documentation.softwareag.com/
http://techcommunity.softwareag.com/


2 

 

 

1.0 Critical Information 
This section lists any critical issues for the current release that were known when this readme was 
published. For critical information found later, go to the Knowledge Center on the Empower website. 

2.0 Known Issues 
This section lists any issues for the current release that were known when this readme was published. 
For known issues found later, go to the Knowledge Center on the Empower website. 

▪ SDEF-2914 

When you launch Designer as a normal user in any Windows Server version and click “Installation 
Details” in the “About Software AG Designer” dialog box (Help > About Software AG Designer), it 
throws the following exception, 

“java.lang.IllegalStateException: Profile not locked due to exception: 

<Profile_location> (Access is denied)” 

As a workaround, launch Designer as an Administrator to view the installation details. 

▪ SDEF-2797 

Designer 10.7 uses Eclipse 4.15 and it does not display the process name, host name, and port 
details in the "Window > Show View > Other > General > Console" view. 

There is no workaround for this issue. 

▪ SDEF-2801 

Designer does not display the memory heap status monitor on the status bar after it is launched. 

As a workaround for this issue, you can enable the heap status function by selecting the 'Show heap 
status' option under 'Window > Preferences > General'. 

▪ SDEF-2782 

In Software AG Designer, when the project presentation view is changed from hierarchical to flat 
under the Project Explorer, Designer does not render and display the resources properly. 

As a workaround for this issue, you can either press F5 to refresh the resources or mouse hover on 
the project tree so that the resources are displayed correctly. 

▪ SDEF-2269 
Secure storage master password provider that uses Windows APIs to encrypt a randomly 
generated 'master' password specific to the login credentials, fails to work in Amazon EC2 

https://empower.softwareag.com/
https://empower.softwareag.com/
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Windows 2012 R2 server system. An exception is displayed "Unable to encrypt master password for 
storage." in that case. 
To work around this problem, navigate to Designer secure storage preference. Clear Windows 
Integration provider option. This would then use the "UI prompt" master password provider. 

▪ SDEF-1832 
On Mac OS X, the layout of Software AG Designer installation has changed to keep in line with 
Eclipse 4.5. As part of the layout change, the shell script designerc.sh is used to launch Software AG 
Designer. You can customize the bash script at Designer/Eclipse.app/Contents/MacOS/designerc.sh 
file. However, there is an issue with restarting Software AG Designer from within the Workbench. 
To work around this issue, close Software AG Designer and relaunch.  

3.0 Usage Notes 
This section provides any additional information you need to work with the current release of Software 
AG Designer. 

▪ The Eclipse update sites listed in Window > Preferences > Install/Update > Available Software Sites 
have been disabled. Software AG does not recommend using these sites to update Designer’s 
Eclipse platform because doing so might have undesired consequences. Use the Software AG 
Update Manager to apply updates to Designer. 

▪ On RHEL 7, while Software AG Designer is starting up, the following alert message appears:  
“Software AG Designer is not responding”  
This message indicates that the initialization of Designer is in progress and does not indicate any 
issue with Designer. Software AG recommends that you click Wait in the alert message window 
and wait until Designer starts up completely. 

▪ Opening an editor freezes the Designer workstation due to a gtk bug 
https://bugzilla.gnome.org/show_bug.cgi?id=686838. 

To work around the problem, add the following Java option in the ‘eclipse.ini’ file: 

▪ Dorg.eclipse.swt.internal.gtk.disablePrinting 

▪ To Setup Software AG Designer in Linux platform, refer to 
http://www.eclipse.org/swt/faq.php#browserwebkitgtk for recommended configurations. 
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4.0 Fixes Included in Each Release 
This section lists the latest fix level that has been included in each release for each product component. 
A release is listed in this section only if changes occurred in that release. Go to the Knowledge Center 
on the Empower website for detailed information about fixes. 

Release 10.7 

▪ SDF_10.5_Fix1 

Release 10.4 

▪ SDF_10.3_Fix1 

Release 10.2 

▪ SDF_9.12_Fix1 

▪ SDF_9.10_Fix2 

▪ SDF_10.1_Fix1 

▪ CEP_10.1_Fix1 

Release 10.0 

▪ CEP_9.7_Fix1 

▪ CEP_9.8_Fix1 

Release 9.10 

▪ SDF_9.8_Fix1 

Release 9.8 

▪ SDF_9.7_Fix1 

▪ SDF_9.6_Fix2 

▪ SDF_9.5_SP1_Fix2 

https://empower.softwareag.com/
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Release 9.7 

▪ CEP_9.5_SP1_Fix4  

▪ SDF_9.6_Fix1  

▪ SDF_9.5_SP1_Fix1  

Release 9.6 

▪ CEP_9.5_SP1_Fix3 

5.0 Other Resolved Issues 
This section lists the issues that were resolved in each release but were not part of the fixes listed in the 
previous section. A release is listed in this section only if changes occurred in that release. 

Release 10.5 

▪ SDEF-2369 
On Linux platform (RHEL 7.3 or SUSE 12) 
 
Designer stops responding on accessing SWT browser. This is due to the Eclipse bug 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=467646. 
Designer support for XULRunner 31.x is not available. To work around this issue, downgrade 
XULRunner version. 
 
Upon clicking Help > About Software AG Designer, Designer displays the error message 
“MOZILLA_FIVE_HOME not set”.  

Also, the Welcome page for Designer does not appear properly. The links on the page are not 
ordering correctly and some icons on the Welcome page are not displayed. To resolve these 
problems, following JVM options in the ‘eclipse.ini’ file had to be added: 
- Dorg.eclipse.swt.browser.DefaultType=Mozilla 
- Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner 
 
These issues are resolved. 

▪ SDEF-1929 
In high screen resolution, Designer does not auto-scale icons and fonts as per the specified DPI. 
This issue occurs as a result of Eclipse Bug 462952. 
This issue is resolved. 

▪ SDEF-1960 
On Windows 10 operating system, Designer does not have default preference for the user interface 



6 

 

appearance. This causes a difference in the appearance of Designer user interface. 
To work around this issue, you must select the appearance theme in the Preferences page. In 
Preferences > General > Appearance, select Windows as Theme and select Default (current) as Color 
and Font theme. Restart Designer.  

       This issue is resolved. 

Release 9.12 

▪ SDEF-2006 
When Designer is launched for the first time from the Start menu, the following error message 
appears: “An internal error occurred during: "Setup check". There is no eclipse.launcher property 
defined”. This error message can be ignored and does not notify any problem with the Designer 
setup. This issue occurs due to Eclipse bugs 471731 and 464122. 
This issue is resolved. 

Release 9.10 

▪ SDEF-1185 
The context menu in the Project Explorer view of Designer displays the Import option twice upon 
deleting a project from the Project Explorer view. 
This issue occurs as the result of the Eclipse Bug 448873.  
This issue is resolved. 

▪ SDEF-1495 
Designer displays the same icons multiple times in the toolbars of various views in Designer upon 
resetting a perspective to its original layout. 
This issue occurs due to an Eclipse known issue Bug 448873.  
This issue is resolved. 

Release 9.8 

▪ SDEF-1339 
Designer requires an installation of Java SE in order to run on Mac OS X. 
If no other Java SE is installed apart from the JVM that was installed with Designer, Designer 
running on Mac OS X displays a message at startup stating that a Java SE Runtime must be 
installed. 
This issue is resolved. To resolve this issue, a new shell script, designerc.sh, is provided to launch 
Designer from a terminal shell. This shell script is available in the Software AG root installation 
directory/Designer/eclipse directory. Alternatively, installing Java SE also resolves this issue. In 
both these cases, Designer will use the JVM provided by Software AG. 

▪ SDEF-1575 
Designer updated to include JGit version 3.4.2 that resolves a JGit client vulnerability in Eclipse. 
A vulnerability affecting all versions of Git clients was announced in https://github.com/blog/1938-

https://github.com/blog/1938-vulnerability-announced-update-your-git-clients
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vulnerability-announced-update-your-git-clients (Eclipse Bug 456947).  
This problem is resolved in JGit version 3.4.2, which is shipped along with Designer 9.8. 

▪ SDEF-1498 
After configuring NTLM authentication for the process audit database in Integration Server, 
Designer issues the following error when testing the connection:  
[SoftwareAG][SQLServer JDBC Driver]NTLM (type-2) Authentication was requested but the 
required DDJDBCx64Auth05.dll was not found on the path specified by the java.library.path 
system property. 
This issue is resolved. 

▪ SDEF-1280 
Right-clicking in the SVN Repositories view does not display the context menu. 
When you right-click in the SVN Repositories view in Software AG Designer, the context menu 
does not show up. The menu is displayed only after right-clicking several times. The problem 
occurs due to Eclipse 4.3 compatibility issues with the SVN Repositories right-click context menu. 
This issue is resolved. 

▪ SDEF-915 
When defining a Software AG Runtime instance in the Servers view, two Password Required dialog 
boxes appear.  
When you define a Software AG Runtime instance in the Servers view after starting Designer with 
a new workspace, two Password Required dialog boxes appear when you select the Platform 
Manager URL box. 
This issue is resolved. 

Release 9.7 

▪ SDEF-1243 
Creating a Software AG Runtime instance using a secure connection fails.  
In the Servers View, when you attempt to create a Software AG Runtime instance using an https 
Platform Manager URL and then click 'List Servers', Software AG Designer returns an error and no 
connection is established. 
The issue is resolved. A secure connection is now the default when creating a Software AG Runtime 
instance. 

▪ SDEF-917 
Fix names are not clearly displayed in Software AG Designer. 
Software AG Eclipse features and plug-ins encode the fix number as the fourth part of their full 
versions. For example, the version 8.2.3.0001-0235 represents fix #1 of version 8.2, service pack 3, 
build 235. In addition, a single product might comprise several features, and a fix might update 
only some features. Thus, identifying the latest fix becomes complex. 
The About Software AG Designer dialog box has been enhanced to display clear information about 
the installed products, organized in tabs according to the provider. 
The Software AG tab displays all installed Software AG products by name, including version and 
the highest fix number, if a fix has been applied. For example:  

https://github.com/blog/1938-vulnerability-announced-update-your-git-clients
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webMethods Service Development  
Version 9.7 (fix #3 applied)  

▪ SDEF-916 
The button labels in the About Software AG Designer dialog box do not provide information about 
the installed products. 
The button tool-tips in the About Software AG Designer dialog box display the provider name, for 
example Software AG, instead of the product name. When checking the version and fix level of  
a Designer plug-in, you might need to click a number of buttons before identifying the correct 
button for the product. 
Now the About Software AG Designer dialog box displays clear information about the installed 
products, organized in tabs according to the provider. 
The Software AG tab displays all installed Software AG products by name, including version and 
fix number, if a fix has been applied. For example:  
webMethods Service Development  
Version 9.7 (fix #3 applied)  
In addition, the button tool-tips display the Eclipse feature(s) related to a product. 

Release 9.6 

▪ SDEF-1291 
The New Server wizard in Software AG Designer displays an incorrect error message when 
validating an IPv6 address. 
While creating a new Software AG Runtime server in Designer, if you provide an invalid IPv6 
address in the Platform Manager URL field, the New Server wizard displays the following incorrect 
error message: "Cannot connect to the Platform Manager. Check the URL and the credentials."  
This issue is resolved. Now the New Server wizard displays the message: "The URL is invalid." 

▪ SDEF-1010 
Software AG Designer does not display the Welcome page properly. 
On the Welcome page in Designer, when you click the “Visit Software AG Community Website” 
link and then go back to the Welcome page using the "Navigate to previous topic" arrow, Designer 
displays an empty Welcome page. 
This issue is resolved. Now Designer opens the “Software AG Community Website” link in an 
external window. 

▪ SDEF-894 
When the Welcome page of Software AG Designer is open as a view, the page does not inform you 
that you have no products installed. 
With only Designer installed, when you open the Welcome page and then double-click the page 
tab, the minimized Welcome page does not display the message: "You have no installed products." 
This issue is resolved. 

▪ SDEF-893 
The Welcome page of Software AG Designer is not displayed properly after using the "Customize 
page" toolbar icon. 
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When you click the "Customize page" toolbar icon on the Designer Welcome page and select a 
home page theme other than Software AG, the Welcome page layout becomes unreadable. 
This issue is resolved. The "Customize page" icon is no longer available. 

6.0 Documentation Changes 
This section describes significant changes to the documentation, such as the addition, relocation, or 
removal of product guides, online help, chapters, or other major content. A release is listed in this 
section only if changes occurred in that release. 

Release 10.7 

▪ A new section, “Secure Storage Runtime Options” is added under the topic, “Configuring the 
Secure Storage” in the online help set, Tips, Training, and Other Resources and the PDF publication, 
Working with Software AG Designer. 

Release 9.12 

▪ A new topic, “Configuring the Secure Storage “is included in the online help set Tips, Training, and 
Other Resources and the PDF publication, Working with Software AG Designer. 

Release 9.10 

▪ The following new topics are included in the online help set Tips, Training, and Other Resources and 
in the PDF publication Working with Software AG Designer: 

▪ Enabling Automatic Updates 

▪ Enabling Eclipse Update Sites 

▪ Enabling Error Reporting Notifications 

▪ Enabling Preference Recorder 

Release 9.9 

▪ The following new topics are included in the online help set Tips, Training, and Other Resources and 
in the PDF publication Working with Software AG Designer: 

▪ Verifying Java Byte Code 

▪ Java Code Cache 
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Release 9.8 

▪ Software AG documentation is no longer available on the Software AG installer. You can access all 
Software AG documentation on the Documentation website. 
Note: Software AG Designer online help and other online helps that are installed along with 
Designer features are still available as part of Designer Eclipse Help under the Software AG 
Designer Guides node. However, the Designer documentation that is available on the 
Documentation website might contain more comprehensive information about the new features. 

▪ Working with Software AG Designer now contains a new topic, Managing the Designer User 
Configuration, which includes information that was available in the following topics as well 
additional information related to installing Designer into a subfolder of Program Files: 

▪ Implementing a Multi-User Eclipse Configuration 

▪ Configuring Eclipse for Non-Administrator Accounts  

▪ Considerations when Starting Designer on Windows 

Release 9.7 

▪ A new section, “Finding Installed Products, Versions, and Fixes”, has been added to the PDF 
publication Working with Software AG Designer and to the online help set Tips, Training, and Other 
Resources. 

Release 9.6 

▪ A new section, “Considerations when Starting Designer on Windows”, has been added to the PDF 
publication Working with Software AG Designer and to the online help set Tips, Training, and Other 
Resources. 

Release 9.5 

▪ The topic “Configuring SSL Connections in Designer” is added to the online help set Tips, Training, 
and Other Resources and to the PDF publication Working with Software AG Designer. 

http://documentation.softwareag.com/
http://documentation.softwareag.com/
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7.0 Added, Removed, Deprecated, or Changed Items 
This section lists functionality, controls, portlets, properties, or other items that have been added, 
removed, deprecated, or changed. A release is listed in this section only if changes occurred in that 
release. 

Release 10.7 

Changed Item Description 

Eclipse version upgrade 

 

Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.15. 

Release 10.5 

Changed Item Description 

Eclipse version upgrade Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.11.0. 

Release 10.3 

Changed Item Description 

Eclipse version upgrade 

 

Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.7.3. 

Release 10.1 

Changed Item Description 

Eclipse version upgrade 

 

Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.6.3. 

  

Release 9.12 

Changed Item Description 

Eclipse version upgrade 

 

Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.5.2. 
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Changed Item Description 

Default encrypting algorithm Software AG Designer is enhanced with 
PBEWithSHA1AndDESede as the preselected 
algorithm. 

Release 9.10 

Removed Item Replacement, if any 

CVS Support CVS is no longer included with Eclipse packages 
by default. 

You can install CVS integration component into 
Software AG Designer from the Eclipse 
Marketplace.  

Changed Item Description 

Eclipse version upgrade Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse 
4.5. 

Release 9.9 

Changed Item Description 

Eclipse version upgrade Software AG Designer and all its plug-ins are now 
supported on the latest service release of Eclipse, 
4.4.2. 

Release 9.8 

Added Item Description 

Installation folder for Designer  It is now possible to install Designer in a subfolder 
of Program Files. 

 

Changed Item Description 

Eclipse version upgrade Software AG Designer and all its plug-ins are now 
supported on Eclipse 4.4. 
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Release 9.7 

Added Item Description 

Ability to select and copy product information 
from the Software AG Preferences page. 
 

It is now possible to select some or all rows in the 
Installed Software AG Features table and copy the 
information to the clipboard. 

Changed Item Description 

"About Software AG Designer" dialog box. The "About Software AG Designer" dialog box was 
redesigned and enhanced to display installed 
products categorized by provider. It displays 
information about version and applied fixes for the 
products provided by Software AG. 

Release 9.6 

Removed Item Replacement, if any 

“Customize page” icon on Welcome page.   

 

Changed Item Description 

Eclipse update sites are disabled by default.  The Eclipse update sites listed in Window > 
Preferences > Install/Update > Available Software 
Sites have been disabled. Software AG does not 
recommend using these sites to update Designer’s 
Eclipse platform because doing so may have 
undesired consequences. 

Release 9.5 

Software AG Designer is now based on Eclipse version 4.3. The plugins that Software AG provides are 
developed and tested for Eclipse version 4.3. 

8.0 Copyright Information 
Copyright © 2020 Software AG, Darmstadt, Germany and/or Software AG USA Inc., Reston, VA, USA, 
and/or its subsidiaries and/or its affiliates and/or their licensors. 

The name Software AG and all Software AG product names are either trademarks or registered 
trademarks of Software AG and/or Software AG USA Inc. and/or its subsidiaries and/or its affiliates 
and/or their licensors. Other company and product names mentioned herein may be trademarks of 
their respective owners. 

Detailed information on trademarks and patents owned by Software AG and/or its subsidiaries is 
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located at http://softwareag.com/licenses.  

This software may include portions of third-party products. For third-party copyright notices, license 
terms, additional rights or restrictions, please refer to "License Texts, Copyright Notices and 
Disclaimers of Third Party Products". For certain specific third-party license restrictions, please refer to 
section E of the Legal Notices available under "License Terms and Conditions for Use of Software AG 
Products / Copyright and Trademark Notices of Software AG Products". These documents are part of 
the product documentation, located at http://softwareag.com/licenses and/or in the root installation 
directory of the licensed product(s). 

9.0 Support 
Visit the Empower website to learn about support policies and critical alerts, read technical articles and 
papers, download products and fixes, submit feature/enhancement requests, and more. 

Visit the TECHcommunity website to access additional articles, demos, and tutorials, technical 
information, samples, useful resources, online discussion forums, and more. 

DES-RM-107-20201015 
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